import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+\\s+\\S+\\s+CIR(?:(?!\\sEast Bernstadt)\\s+East)?(?:\\s+East Bernstadt)?(?: +\\d+)?";
final String string = "2320 ZINER CIR East 43123\n"
+ "1111 ZINER CIR East Bernstadt 43123\n"
+ "1234 Ziner CIR East East Bernstadt";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}