$re = '/\d+\s+\S+\s+CIR(?:(?!\sEast Bernstadt)\s+East)?(?:\s+East Bernstadt)?(?: +\d+)?/m';
$str = '2320 ZINER CIR East 43123
1111 ZINER CIR East Bernstadt 43123
1234 Ziner CIR East East Bernstadt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);