re = /\d+\s+\S+\s+CIR(?:(?!\sEast Bernstadt)\s+East)?(?:\s+East Bernstadt)?(?: +\d+)?/m
str = '2320 ZINER CIR East 43123
1111 ZINER CIR East Bernstadt 43123
1234 Ziner CIR East East Bernstadt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end