#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^\s*(?:(final)\s+)?(int|double|String|boolean|char)\s+(?:(?:(\w+)\s*(?:\=\s*(\w+))?\,?\s*)+)\;\s*$"
Local $sString = "final String var_name = 3;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")