import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(?:(final)\\s+)?(int|double|String|boolean|char)\\s+(?:(?:(\\w+)\\s*(?:\\=\\s*(\\w+))?\\,?\\s*)+)\\;\\s*$";
final String string = "final String var_name = 3;";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}