// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^\s*(?:(final)\s+)?(int|double|String|boolean|char)\s+(?:(?:(\w+)\s*(?:\=\s*(\w+))?\,?\s*)+)\;\s*$").unwrap();
let string = "final String var_name = 3;";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}