#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([ab])([0-9]+)\(([0-9]*)\)"
Local $sString = "kau(77)j8g(99)sib(88)a21(5)w" & @CRLF & _
"kau(77)j8g(99)sib(88)a21(5)wkau(77)j8g(99)sib(88)a21(5)w"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")