re = /([ab])([0-9]+)\(([0-9]*)\)/m
str = 'kau(77)j8g(99)sib(88)a21(5)w
kau(77)j8g(99)sib(88)a21(5)wkau(77)j8g(99)sib(88)a21(5)w'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end