// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([ab])([0-9]+)\(([0-9]*)\)").unwrap();
let string = "kau(77)j8g(99)sib(88)a21(5)w
kau(77)j8g(99)sib(88)a21(5)wkau(77)j8g(99)sib(88)a21(5)w";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}