import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:settingsB *=|\\G(?!^) *,) *([\\d.]+)";
final String string = "settingsA=9, 4.2 \n"
+ "settingsB=3, 1.5, 9, 2, 4, 6\n"
+ "settingsC=8, 3, 2.5, 1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}