const regex = /(?:settingsB *=|\G(?!^) *,) *([\d.]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:settingsB *=|\\G(?!^) *,) *([\\d.]+)', 'g')
const str = `settingsA=9, 4.2
settingsB=3, 1.5, 9, 2, 4, 6
settingsC=8, 3, 2.5, 1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}