re = /(?:settingsB *=|\G(?!^) *,) *([\d.]+)/
str = 'settingsA=9, 4.2
settingsB=3, 1.5, 9, 2, 4, 6
settingsC=8, 3, 2.5, 1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end