using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b(?<!['""])[a-zA-Z_][a-zA-Z_0-9]*\b(?!['""]))";
string substitution = @"<span class="">\0</span>";
string input = @"steve
""john""
'leo'
sophie
""john
eliott""
'john
john'
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}