use strict;
my $str = 'steve
"john"
\'leo\'
sophie
"john
eliott"
\'john
john\'
';
my $regex = qr/(\b(?<!['"])[a-zA-Z_][a-zA-Z_0-9]*\b(?!['"]))/p;
my $subst = '<span class="">\\0</span>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";