# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\b(?<!['\"])[a-zA-Z_][a-zA-Z_0-9]*\b(?!['\"]))"
test_str = ("steve \n"
"\"john\" \n"
"'leo' \n"
"sophie\n"
"\"john\n"
"eliott\"\n"
"'john\n"
"john'\n")
subst = "<span class=\"\">\\0</span>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.