using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"g3\d+(?:(?!g2).)*g1\d+";
string input = @"g31 a bunch of anything or nothing g11
g31g11
g31 a bunch of anything or nothing g21 a bunch of anything or nothing g11
g31g21g11";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}