re = /g3\d+(?:(?!g2).)*g1\d+/
str = 'g31 a bunch of anything or nothing g11
g31g11
g31 a bunch of anything or nothing g21 a bunch of anything or nothing g11
g31g21g11'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end