import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "g3\\d+(?:(?!g2).)*g1\\d+";
final String string = "g31 a bunch of anything or nothing g11 \n"
+ "g31g11\n\n"
+ "g31 a bunch of anything or nothing g21 a bunch of anything or nothing g11\n"
+ "g31g21g11";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}