#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)20[\d-T:.Z+]+$(?!\r?\nR)"
Local $sString = "2021-12-07T16:39:43+01:00" & @CRLF & _
"M test.md" & @CRLF & _
"" & @CRLF & _
"2021-12-07T16:18:59+01:00" & @CRLF & _
"R100 old.test.md test.md" & @CRLF & _
"" & @CRLF & _
"2021-12-07T15:37:15+01:00" & @CRLF & _
"A old.test.md"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")