using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"20[\d-T:.Z+]+$(?!\r?\nR)";
string input = @"2021-12-07T16:39:43+01:00
M test.md
2021-12-07T16:18:59+01:00
R100 old.test.md test.md
2021-12-07T15:37:15+01:00
A old.test.md";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}