const regex = /20[\d-T:.Z+]+$(?!\r?\nR)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('20[\\d-T:.Z+]+$(?!\\r?\\nR)', 'gm')
const str = `2021-12-07T16:39:43+01:00
M test.md
2021-12-07T16:18:59+01:00
R100 old.test.md test.md
2021-12-07T15:37:15+01:00
A old.test.md`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}