using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.{21})[A-Za-z\d]+-?[A-Za-z\d]*\b$";
string input = @"-
-foo
foo-
foobar
foobar-foobar
foobarbazfoobarbazfo
foobarbazfoobarbazfoo";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}