$re = '/^(?!.{21})[A-Za-z\d]+-?[A-Za-z\d]*\b$/m';
$str = '-
-foo
foo-
foobar
foobar-foobar
foobarbazfoobarbazfo
foobarbazfoobarbazfoo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);