re = /^(?!.{21})[A-Za-z\d]+-?[A-Za-z\d]*\b$/m
str = '-
-foo
foo-
foobar
foobar-foobar
foobarbazfoobarbazfo
foobarbazfoobarbazfoo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end