re = /'[\w|\s]*([']*)[\w|\s]*'/mi
str = '\'sinead o\'connor\',\'don\'t don\'t\',\'whatever\', \'sas1\'23\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end