import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*((?:const\\s+|virtual\\s+|friend\\s+|volatile\\s+){0,4}\\s*?(?:\\w+\\s*::)?\\s*[\\w]+)\\s+(\\w+)\\s*\\([\\s\\S]*?\\)\\s*(const)?\\s*\\{";
final String string = "#include \"Port.h\"\n\n"
+ "namespace Port {\n\n"
+ " uint8_t lirePin(volatile uint8_t * pin)\n"
+ " {\n"
+ " return * pin;\n"
+ " }\n"
+ " /*********************************************************************\n"
+ " * retourne vrai si les pin du port pin sont ouvert\n"
+ " * pin = PINA a PIND\n"
+ " *********************************************************************/\n"
+ " bool lirePin(uint8_t pins, volatile uint8_t * pin)\n"
+ " {\n"
+ " return (*pin & pins);\n"
+ " }\n"
+ " /*********************************************************************\n"
+ " * Met la pin du port port a 5V\n"
+ " * port = PORTA a PORTD\n"
+ " *********************************************************************/\n"
+ " void ouvrirPin(uint8_t pins, volatile uint8_t * port)\n"
+ " {\n"
+ " *port |= pins;\n"
+ " }\n"
+ " /*********************************************************************\n"
+ " * Met la pin du port port a 0V\n"
+ " * port = PORTA a PORTD\n"
+ " *********************************************************************/\n"
+ " void fermerPin(uint8_t pins, volatile uint8_t * port)\n"
+ " {\n"
+ " *port &= ~pins;\n"
+ " }\n"
+ " /*********************************************************************\n"
+ " * Met la pin du port ddr en Entree\n"
+ " * ddr = DDRA a DDRD\n"
+ " *********************************************************************/\n"
+ " void pinEntree(uint8_t pins, volatile uint8_t * ddr)\n"
+ " {\n"
+ " *ddr &= ~pins;\n"
+ " }\n"
+ " /*********************************************************************\n"
+ " * Met la pin du port ddr en Sortie\n"
+ " * ddr = DDRA a DDRD\n"
+ " *********************************************************************/\n"
+ " const volatile friend std::void pinSortie(uint8_t pins, \n"
+ "volatile uint8_t * ddr)\n"
+ " {\n"
+ " *ddr |= pins;\n"
+ " }\n"
+ " /*********************************************************************\n"
+ " * Met le port ddr en Entree\n"
+ " * ddr = DDRA a DDRD\n"
+ " *********************************************************************/\n"
+ " void portEntree(volatile uint8_t * ddr) const\n"
+ " {\n"
+ " *ddr = ENTREE;\n"
+ " }\n"
+ " /*********************************************************************\n"
+ " * Met le port ddr en Entree\n"
+ " * ddr = DDRA a DDRD\n"
+ " *********************************************************************/\n"
+ " void portSortie(volatile uint8_t * ddr)\n"
+ " {\n"
+ " *ddr = SORTIE;\n"
+ " }\n"
+ " \n"
+ "}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}