using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href=\""[^""]+\""";
string input = @"class=""thumb vtop inlblk rel tdnone linkWithHash scale5 detailsLink"" href=""http://olx.com.pk/item/honda-civic-exi-2005-IDSkzkt.html#6256e9ac30"" title=""> ";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}