import re
regex = re.compile(r"href=\"[^\"]+\"")
test_str = "class=\"thumb vtop inlblk rel tdnone linkWithHash scale5 detailsLink\" href=\"http://olx.com.pk/item/honda-civic-exi-2005-IDSkzkt.html#6256e9ac30\" title=\"\"> "
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")