// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"href=\"[^"]+\""#).unwrap();
let string = "class=\"thumb vtop inlblk rel tdnone linkWithHash scale5 detailsLink\" href=\"http://olx.com.pk/item/honda-civic-exi-2005-IDSkzkt.html#6256e9ac30\" title=\"\"> ";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}