package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<[a-zA-Z]+.+?>)`)
var str = `<a href="http://cdn.xyz.com/media/info.pdf" target="_blank">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}