$re = '/(<[a-zA-Z]+.+?>)/m';
$str = '<a href="http://cdn.xyz.com/media/info.pdf" target="_blank">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);