re = /(<[a-zA-Z]+.+?>)/m
str = '<a href="http://cdn.xyz.com/media/info.pdf" target="_blank">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end