import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=FROM|JOIN|OJ)[\\s\\(]+(((`?[\\w_]+`?)(\\s*,\\s*)*)+)";
final String string = "select * from users, cusotmers join (`table3`, table4, (select * from table5 where a=b))";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}