$re = '/(?<=FROM|JOIN|OJ)[\s\(]+(((`?[\w_]+`?)(\s*,\s*)*)+)/i';
$str = 'select * from users, cusotmers join (`table3`, table4, (select * from table5 where a=b))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);