re = /(?<=FROM|JOIN|OJ)[\s\(]+(((`?[\w_]+`?)(\s*,\s*)*)+)/i
str = 'select * from users, cusotmers join (`table3`, table4, (select * from table5 where a=b))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end