const regex = /^abc$|i10n/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^abc$|i10n', '')
const str = `abc
i10n
10abc
abcабвгд
abc.3 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}