const regex = /(?<=version\s)(\S+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=version\\s)(\\S+)', '')
const str = `Linux version 3.10.49-g5796782 (d00903065@ubuntu)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}