$re = '/(?<=version\s)(\S+)/';
$str = 'Linux version 3.10.49-g5796782 (d00903065@ubuntu)
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);