re = /(?<=version\s)(\S+)/
str = 'Linux version 3.10.49-g5796782 (d00903065@ubuntu)
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end