const regex = /^[a-zA-Z0-9!@#$%^&*()\[\]{};'’`\-\\:,.\/<>?| ]{60,150}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z0-9!@#$%^&*()\\[\\]{};\'’`\\-\\\\:,.\\\/<>?| ]{60,150}$', '')
const str = `For example we wouldn\`t want a &@* :- user to have to wait for their new user signup email to get emailed to them.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}