re = /^[a-zA-Z0-9!@#$%^&*()\[\]{};'’`\-\\:,.\/<>?| ]{60,150}$/
str = 'For example we wouldn`t want a &@* :- user to have to wait for their new user signup email to get emailed to them.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end