package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(\d{2}:\d{2}:\d{2})|([0-9a-z]*.xml)`)
var str = `Time 2014-05-22T10:39:04.890117+01:00 Filename S140522DSS10002.xml::938c287eb522359b600f74bb3140bb64 Generated 2014-05-22T10:38:46.000000+01:00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}