const regex = /(\d{2}:\d{2}:\d{2})|([0-9a-z]*.xml)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{2}:\\d{2}:\\d{2})|([0-9a-z]*.xml)', 'gmi')
const str = `Time 2014-05-22T10:39:04.890117+01:00 Filename S140522DSS10002.xml::938c287eb522359b600f74bb3140bb64 Generated 2014-05-22T10:38:46.000000+01:00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}