const regex = /(?:\w_){3}(\d{8})T\d{4}_\1T\d{4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\w_){3}(\\d{8})T\\d{4}_\\1T\\d{4}', 'gm')
const str = `A_B_C_20222020T1420_20222020T1010`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}