$re = '/(?:\w_){3}(\d{8})T\d{4}_\1T\d{4}/m';
$str = 'A_B_C_20222020T1420_20222020T1010';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);