import re
regex = re.compile(r"(?:\w_){3}(\d{8})T\d{4}_\1T\d{4}", flags=re.MULTILINE)
test_str = "A_B_C_20222020T1420_20222020T1010"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")