import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(BEGIN:VEVENT\\n|(?!^)\\G)(?:([A-Z;-]+)[:=][^\\n]+)";
final String string = "BEGIN:VEVENT\n"
+ "SUMMARY:Marché légumes Dilbeek et bibliothèque#DTSTART;TZID=Europe/Paris:20130928T084500\n"
+ "DTEND;TZID=Europe/Paris:20130928T094500\n"
+ "DTSTAMP:20160126T214559Z\n"
+ "UID:aHR0cHM6Ly8xOTIuMTY4LjEuMjIwOjQ0MzIvb3duY2xvdWQvcmVtb3RlLnBocC9jYWxkYXYvY2FsZW5kYXJzL2FuZ2Vsby9kZWZhdWx0Y2FsZW5kYXIvOTkwM2QyNTctZjY2Ny00ZWI3LWFjZDEtNWJlZmI0NGQ0MmJlLmljcw==@google.com\n"
+ "RECURRENCE-ID;TZID=Europe/Paris:20130928T090000\n"
+ "SEQUENCE:1\n"
+ "CREATED:20160126T214559Z\n"
+ "LAST-MODIFIED:20160126T214559Z\n"
+ "STATUS:CONFIRMED\n"
+ "TRANSP:OPAQUE\n"
+ "END:VEVENT";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}