use strict;
my $str = 'BEGIN:VEVENT
SUMMARY:Marché légumes Dilbeek et bibliothèque#DTSTART;TZID=Europe/Paris:20130928T084500
DTEND;TZID=Europe/Paris:20130928T094500
DTSTAMP:20160126T214559Z
UID:aHR0cHM6Ly8xOTIuMTY4LjEuMjIwOjQ0MzIvb3duY2xvdWQvcmVtb3RlLnBocC9jYWxkYXYvY2FsZW5kYXJzL2FuZ2Vsby9kZWZhdWx0Y2FsZW5kYXIvOTkwM2QyNTctZjY2Ny00ZWI3LWFjZDEtNWJlZmI0NGQ0MmJlLmljcw==@google.com
RECURRENCE-ID;TZID=Europe/Paris:20130928T090000
SEQUENCE:1
CREATED:20160126T214559Z
LAST-MODIFIED:20160126T214559Z
STATUS:CONFIRMED
TRANSP:OPAQUE
END:VEVENT';
my $regex = qr/(BEGIN:VEVENT\n|(?!^)\G)(?:([A-Z;-]+)[:=][^\n]+)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";