# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(BEGIN:VEVENT\n|(?!^)\G)(?:([A-Z;-]+)[:=][^\n]+)"
test_str = ("BEGIN:VEVENT\n"
"SUMMARY:Marché légumes Dilbeek et bibliothèque#DTSTART;TZID=Europe/Paris:20130928T084500\n"
"DTEND;TZID=Europe/Paris:20130928T094500\n"
"DTSTAMP:20160126T214559Z\n"
"UID:aHR0cHM6Ly8xOTIuMTY4LjEuMjIwOjQ0MzIvb3duY2xvdWQvcmVtb3RlLnBocC9jYWxkYXYvY2FsZW5kYXJzL2FuZ2Vsby9kZWZhdWx0Y2FsZW5kYXIvOTkwM2QyNTctZjY2Ny00ZWI3LWFjZDEtNWJlZmI0NGQ0MmJlLmljcw==@google.com\n"
"RECURRENCE-ID;TZID=Europe/Paris:20130928T090000\n"
"SEQUENCE:1\n"
"CREATED:20160126T214559Z\n"
"LAST-MODIFIED:20160126T214559Z\n"
"STATUS:CONFIRMED\n"
"TRANSP:OPAQUE\n"
"END:VEVENT")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.