import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)\n"
+ " (?<curly> \\{ \\g<content>*? \\} )\n"
+ " (?<square> \\[ \\g<content>*? \\] )\n"
+ " (?<pascal> \\bbegin\\b \\g<content>*? \\bend\\b )\n"
+ " (?<lua> --\\[ \\g<content>*? --\\] )\n\n"
+ " (?<nested> \\g<curly> | \\g<square> | \\g<pascal> | \\g<lua> )\n\n"
+ " (?<content>\n"
+ " # Math non-recursive content (atomically)\n"
+ " (?: (?! [\\{\\}\\[\\]] | \\bbegin\\b | \\bend\\b | --[\\[\\]] ) .)++\n"
+ " # Or recurse\n"
+ " | \\g<nested>\n"
+ " )\n"
+ ")\n\n"
+ "\\g<nested>";
final String string = "EVENLY BALANCED curly braces\n\n"
+ "{{{}}}\n"
+ "{ test1 { test2 { test3 { test4 } } } }\n\n"
+ "UNEVENLY BALANCED curly braces\n"
+ "{{{{}}} end <-- this is needed, otherwise this line balances with the line below :)\n"
+ "{ test1 { test2 { test3 { test4 } } } } }\n\n"
+ "MULTI-LINE EVENLY BALANCED curly braces\n"
+ "{\n"
+ "}\n\n"
+ "MULTI-LINE UNEVENLY BALANCED curly braces\n"
+ "{{\n"
+ "}\n\n\n"
+ "EVENLY BALANCED square braces\n"
+ "[ test1 [ test2 [ test3 [ test4 ] ] ] ]\n\n"
+ "EVENLY BALANCED square and curly braces\n"
+ "{ test1 [ test2 { test3 [ test4 ] } ] }\n\n"
+ "UNEVENLY BALANCED square and curly braces\n"
+ "{ test1 [ test2 { test3 [ test4 ] } } ]\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}